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DESKTOP PUBLISHING (DTP)
•Introduction

Publishing is the process of producing publications such as newspapers, cards, 

pamphlets, pictures, calendars, books, etc that has special text and graphical layouts & 

designs.

•Definition of Desktop Publishing

Desktop publishing refers to the process of producing publications by designing their 

text and graphics layout using special desktop publishing software installed on personal 

computers.  The text and graphical objects can then be inserted, edited, formatted and 

printed.

Examples of desktop publishers;
•Adobe PageMaker

•Adobe Photoshop - mainly used for editing & formatting photographs.

•Adobe illustrator - used for creating complex freehand artwork such as drawings & logos.

•CorelDraw.

•Microsoft Publisher.

•Ventura.

•Harvard graphic.



Difference between a desktop publisher and a word processor.

A DTP software gives the user more tools and control of the 

page layout, text manipulation and graphic design than a word 

processor.

However, today’s word processors have been incorporated 

with text and graphic formatting and editing tools, e.g., you 

can design a full publication in Microsoft Word by using the 

available Drawing and Picture tools, create columns, etc.



Purpose of Desktop publishing software

DTP programs give the typesetter (the person designing publications) a lot of control on: 

Graphic design:

Using DTP software, a typesetter can create and edit very complex text & graphical 

objects of high quality.

For example, the software provides the user with rulers & ruler guides that can be used to 

place an object in the correct position within the publication.

Page layout design:

With a desktop publisher, the user can design a page layout by setting consistent 

(constant) picture and object locations, divide a page into a number of columns, and also 

create layers.

Layering is the arrangement of objects on top of each other with the one on top being on 

the first layer. 

Printing:

To produce any publications, they must be printed.  Therefore, DTP software helps the 

user to prepare artwork (i.e., publications that are ready for printing).



Types of Desktop publishing software

There are 2 main types of DTP software:

Graphical based:

They are specifically developed for editing & formatting graphic objects like pictures.

Examples;

 Adobe Photoshop. - Harvard graphic.

 CorelDraw.

Graphic-based desktop publishers have superior capabilities for handling images such as 

setting resolution, brightness, contrast, cropping, and filling the images with colour.

Layout based:

They are specifically developed to create different page layout designs for text and pictures.

Examples;

 Adobe PageMaker.

 Microsoft Publisher.



Designing a publication

Different publications have different design layouts and formatting.

Types of publications

There are several types of publications that can be produced using DTP software.  They include:

Cards:

They may be for special occasions such as weddings, graduations, harambee, and for congratulations.

Certificates:

These are types of publications used to show completion of courses and special events.

Note.  Certificates are very sensitive, and must be designed to discourage any type of duplication or 

counterfeits.

Newspapers, Magazines, Pamphlets and Newsletters:

They contain news targeting a group of people.

Books:

Are bulky publications with many pages that are bound together.

Calendars:

They are used to show dates.  They are also used by companies to advertise their products.

Notices, Brochures, Posters / Advertisement, and Catalogues.



Features of DTP software

1) Text can be entered directly into a DTP publication.  Alternatively, the text can be entered 

into a Word processor and then copied into the DTP document.

 Graphics can be created in a separate program, then incorporated into a Desktop 

publishing program.

 A Scanner can also be used to copy images, such as photographs and drawings, into a 

Desktop publishing document.  A Scanner is a device that reads text and images into a 

document.

2) A DTP program gives you more control over the graphics in a publication.  You can:

move - change the position of a graphic on a page,

size - make a graphic larger or smaller, 

Rotate - turn or spin a graphic, and 

Crop - trim part of a graphic.
3) Has a wide range of Fonts & print sizes that can be merged with useful symbols, such as arrows and stars.Has

Columns of various widths, in which the text is fitted automatically using sensible hyphenation.  The columns 

can also be reorganization automatically.

4) Enables Scaling and cropping of publications so as to fit the available space.

5) Page numbers can be inserted.

6) Enables production of multiple page documents.



Steps in using a DTP System.

Prepare your text and illustrations with a Word processor  or a Graphics package. 

Alternatively, use a Scanner to input text and graphics from other sources.

Using the DTP program, develop the format of each page.

Your screen becomes an electronic paste board with rulers, column guides and 

other page design aids.

Copy the text and illustrations into the page format you have designed in the DTP 

program.

The DTP program will automatically move the excess text to another column or 

page and also help size and place illustrations and headings.

Format the pages on the screen to look the way you want them, then store them 

electronically on your hard disk.  If necessary, print them on a Laser Printer to 

produce the finished printed material.



Printing terminologies used in DTP.

1) Runner – the main headline across the top of the page.

2) Cross head – a small heading used to break up text into easily readable sections.

3) Bullet – solid dot printed before pieces of text in order to add an emphasis.

4) Cast off – a calculation as to how much space the text will use on a page.

5) Footer – a line of text at the bottom of each page giving the publications title, author’s 

name, etc.

6) Masthead – details of the person involved in printing the publication.

7) WYSIWYG (What You See Is What You Get) – this means that, the presentation on the 

screen is exactly what you will get from the Printer.

1) Jigging – moving text around by means of DTP software.



To start Microsoft publisher 

To load the Microsoft Publisher 2007-2019 program, Double 

click on the Publisher 2007-2019 icon on the main Windows 

screen, or click-on Start in the lower left corner of the screen, 

then click-on Programs, and then click on Microsoft Publisher 

2007-2019.





MS Publisher screen
Ribbons PASTE BOARD

PRINTABLE AREARULER



Create a New Publication in Publisher: Instructions
1.A startup screen appears when you first open Publisher, which lets
you create a new publication in Publisher.
2.To create a new publication in Publisher from the startup screen,
click the type of publication to create in the listing of available
templates at the right side of the startup screen.
3.Alternatively, to create a new publication after creating a publication,
then click the “File” tab in the Ribbon.
4.Then select the “New” command at the left side of the backstage
view.
5.Next, click one of the available templates that appears at the right
side of the backstage view.
6.Then click either the “Create” or “Download” buttons that appear to
create a new publication in Publisher from the template.
7.To create a new, blank publication that is a standard page size, select
the “Blank 8.5 x 11” icon from the template list.



Create and edit master pages
Use master pages to repeat design and layout elements on multiple pages in a publication. Using 

master pages for these common elements gives your publication a more consistent appearance and 

allows you to create and update these elements in one place, rather than changing them on each 
publication page

Create or edit master pages
You can create a new master page from scratch or duplicate an existing master page, which you can 

then edit to change just those elements that you want to be different.

If you set up your publication to be viewed as two-page spreads, you should use two-page master 

pages. If you set up your publication to be viewed as single pages, you should use single-page 

master pages.

You can also Change a single-page master page to a two-page master page, or Change a two-page 

master page to a single-page master page.

1.To view the current master pages in your open publication, click View > Master Page.

2.Begin to edit the master page in the master page window by adding elements such as headers and 

footers or page numbers.

3.Click Close Master Page to go back to publication view.

https://support.microsoft.com/en-us/office/99f419dc-dd4f-4548-ba9e-b0526834c647
https://support.microsoft.com/en-us/office/change-a-two-page-master-page-to-a-single-page-master-page-f787c24f-571b-4ff6-8073-63a55fd30578




Add a duplicate page

1.In the page navigation area at the bottom of the screen, right-click 

the page that you want to copy.

2.On the shortcut menu, click Insert Duplicate Page. A duplicate 

page will be inserted into your publication immediately after the 

selected page

Add a page

•In your open publication, turn to the page that will come before or after 

the pages you want to add.

•On the Insert tab, click the arrow below the Page button.

•Select an option: Insert blank page to insert a new blank page after 

the currently selected page.



Page numbering
Like in world document, numbering pages of a publication like books and magazines make it easier to read and 
make references.
To insert a page number 
INSERT tab in the header and footer group, click page number command
Select one of the options e.g. bottom center on the drop down list
Changing page number style
Click page number command
Click format page number command
In the page number format dialog box , in the number format drop down list , select a page number format 
Click OK.
REARRANGING PAGES
in publisher , you can change the order of  your  pages by rearranging page thumbnails in the pages pane. 

Changing the order of pages does not affect the text objects in publications, even thought they may have moved 
to different pages.
Steps
On the pages pane click a page
Drag a page to the required location in the page
INSERTING HEADER AND FOOTER
PAGE DESIGN RIBBON,  in the page background group click master pages command , Select EDIT MASTER PAGES 

from the drop down list on the masters page ribbon in the header and footer group, click the show header and 
footer button, type your header and footer



Layout Guides in Publisher: Types of Layout Guides
You use layout guides in Publisher to help with the layout of page content. There are many

different types of layout guides in Publisher. For example, margin guides appear onscreen to help you
stay within the printable page area. Margin guides are one of the layout guides in Publisher that you
can use when designing publications.

In this lesson, you will learn how to use the different types of layout guides in Publisher, like
ruler guides, baseline guides, and grid guides. You can add layout guides in Publisher by using the
buttons in the “Layout” button group on the “Page Design” tab in the Ribbon.
Layout Guides in Publisher: Using Ruler Guides

The first of the layout guides in Publisher to discuss is the ruler guide. To add a ruler guide to
your page for object alignment, click the “Page Design” tab in the Ribbon. Then click the “Guides”
button in the “Layout” button group. Then choose a set of ruler guides to add from the drop-down
menu.

Alternatively, you could also select the “Add Horizontal Ruler Guide” or “Add Vertical Ruler
Guide” command from the button’s drop-down menu to add a single horizontal or vertical ruler guide
to the center of the page. Alternatively, you can also add ruler guides to your page by clicking directly
into the ruler and then dragging your mouse into the page to place a ruler guide at the location at
which you release your mouse.

To adjust the position of ruler guides onscreen, click and drag them to a new location with your
mouse. To do this, place your mouse pointer over the ruler guide until your mouse pointer turns into a
double-pointed line intersected by an arrow. Then click and drag the guide to the desired location in
the publication. To remove a ruler guide, click and drag it off the publication page into the scratch area.



Page formatting
Is the enhancement of a publication layout  by partitioning a page into columns 
page numbering adding headers and footers

column guides
Helps you divide the pages  into columns that make the publication look more 
organized. The idea is to partition a page into short readable sentence blocks. 
Columns are mostly used in designing large publications like newspapers and 
journals.
CLICK PAGE DESIGN TAB 
In the Layout group, click guides commands
Select the relevant column guides from the drop down list

Insert evenly distributed columns
Click text frame to activate 
click on column button on the format ribbon to display columns drop down list
Select the option with number of preferred columns



Layout Guides in Publisher: Using Grid Guides
To view the grid and baseline guides, click the “Page Design” tab in the

Ribbon. Then click the “Guides” button in the “Layout” button group. Then select
the “Grid and Baseline Guides…” command from the button’s drop-down menu.

In the “Layout Guides” dialog box, the “Grid Guides” tab then appears. You
can create additional columns and rows within a page using the settings on this
tab. Enter the number of columns to show on the page into the “Columns:” spinner
box in the “Column Guides” section. Then enter the desired column spacing to
allocate by using the “Spacing:” spinner buttons in the “Column guides” section.
Enter the number of rows to add to the page into the “Rows:” spinner box in the
“Row Guides” section. Then enter the spacing to allocate between the rows in the
“Spacing:” spinner box.



Here's how to add new text to a page:

1.Click Text Box on the Objects toolbar. (By default, when you 

open Publisher, the Objects toolbar extends vertically along the left side 

of the Publisher window.)

2.Drag to create a rectangle on the page.

3.In the text box you created, type the text you want.



FORMATING TEXT







Change case

1.Select the text for which you want to change the case.

2.Go to Home > Change case .

3.Do one of the following: To capitalize the first letter of a sentence and leave all other 

letters as lowercase, click Sentence case. To exclude capital letters from your text, click 

lowercase.



Formatting text to superscript or subscript

Select the text you want to style as superscript or 
subscript
In font group, click superscript or subscript button

Subscript                                  superscript 



Tracking and kerning are two Publisher options for controlling the space between 

characters. Kerning is helpful for fine-tuning the space between individual characters, 

especially at large font sizes used in display text.

Tracking reduces or increases spaces while kerning changes spacing between two 
specific text characters.



Indent and paragraph formatting 
Alignment and indentation



Editing a publication
Find and replace
You can search for specific occurrences of word or group of words in your 
publication.
To find and change a word or phrase in the publication
On HOME ribbon in the editing group, click the replace command
The find and replace pane appears
In the search for box type the word or phrase to search
In the replace with box, type the new word that will replace
Click on replace or replace all

Checking for spelling mistakes
Click REVIEW tab then in the proofing group click the spelling command. 



Inserting objects , graphics, pictures and auto shapes 

Picture                                           auto shapes                                                      word Art  date and time             headers



Importing graphical objects
Click picture insert picture
Select file then insert
GROUPING AND UNGROUPING OBJECTS
Using a pointer tool, hold down the shift key as you click the objects to be grouped
Click group button located in the arrange group of format ribbon 
to ungroup
select the Group
Click the Ungroup button text to Group button. 
ROTATING AN OBJECT
Click the object
Click on Rotate button  in the Arrange group
Select rotation option 

Cropping an object
after inserting a picture or a clip art into your publication, you may want to hide parts of the 
graphic that  you do not want to be printed. This process is referred to as cropping. 
Click on the image then click on CROP TOOL



Fill and stroke
Stroke Refers to line style applied around an object or text while fill is the style applied in the text or object 
block TO APPLY RIGH CLICK ON THE AUTO SHAPE



Change the color of fills, lines, and borders
Publisher for Microsoft 365 Publisher 2019 Publisher 2016 Publisher 2013 More...
1.Right-click the object you want to change, and then click Format <object type>.

2.The Format <object type> dialog box appears.

3.On the Colors and Lines tab, select the options you want:

4.Change a fill

5.Color -Select the fill color that you want from the palette, or select one of the options 

in the list:

1.Scheme Colors – Select colors from the applied color scheme of your publication.

2.Standard Colors – Select from a standard set of colors ranging from red to blue.

3.No Fill - Click this option to give the selected cells or table no fill of any kind. Cells 

with no fill have a transparent background.

4.More Colors - Click this option to open the Colors dialog box. You can select a 

new color from the standard color palette, or you can select a custom color that 

you can define by using the RGB, HSL, or CMYK color model. You can also select a 

PANTONE® color.



Wrap text around a picture in Publisher

1.Click the picture to select it.

2.On the Format tab, in the Arrange group, 

click Wrap Text.

3.Do one of the following: Click Square to wrap 

text around the border of your image. Click Tight 

to wrap text closely around an irregularly shaped 

picture. Click Top and Bottom to place the image on 

its own line.



Inserting tables 
Create a table and add text

1.Click where you want the table to appear in your publication .

2.On the Ribbon toolbar, click Insert, and then select Table and

3.Create your table by dragging across the row or column squares to create the rows and 

columns.

4.To increase the size of the table, select the table, position the mouse pointer over a selection 

handle until you see the Resizer icon, and then drag to resize the table.

5.In the table, click the cell where you want to add text, and then start typing.

6.To add text to another cell, click inside that cell.

7.Each cell expands to fit your text, unless you lock the table size by clearing the check mark next 

to Grow to Fit Text on the Table menu.

Create a table from existing Publisher text

1.If the text is in a table, select the cells you want.

2.If the text is in a text box, make sure there's a tab or comma between each entry in a row, and a 

paragraph mark at the end of each row.

3.Highlight the text, right-click the highlighted text, and then click Copy.

4.On the Edit menu, click Paste Special.











Printing a publication 

On the File menu, click Print. In the Print dialog 

box, click the Publications and Paper Settings tab. 

Under Print range, click Pages. In the text box, 

type the page number of the first page that you 

want to print, type a comma, and then type the 

next page that you want to print.
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